PGP Mail α

 
Browser not supported!
Reason: We need a cryptographically secure PRNG to be implemented (i.e. the window.crypto method).
Solution: Use Chrome >= 11, Safari >= 3.1 or Firefox >= 21.